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As a recommended practice, rosters for future instructor-led learning activities should be generated the day 
prior to the scheduled event. It is a best practice to process ILT rosters the same business day (if possible), or within 
three business days.  
 
Roster management in myTraining consists of two different processes: 

• Generating rosters for future instructor-led learning activities 
• Processing rosters for completed instructor-led learning activities 

 
NOTE: This instruction guide is designed for administrators of the system, not those individuals designated 
as instructors. To access a roster, the user must have access to Administrator mode in myTraining with the 
necessary permissions enabled. 

 
Generating & Printing Rosters 

• Run Roster Report 
• Manually Create Roster 

Processing Rosters 
• Scheduled Activities 
• Unscheduled Activities 

 
Run Roster Report 

1. Go to mytraining.hr.ufl.edu, select the University of Florida option, log in with GatorLink credentials. 
2. Navigate to Self > Reporting > Advanced Reporting.  
3. Expand through the following folders: mytrainingufshands > Custom > UF > Departmental Reports > 

Training & Org. Development > Reports. 
4. Within the Reports folder you will see several reports. The following two reports are used for ILT Class 

rosters: 
o ILT Class Roster (includes participant’s UFID numbers)  
o ILT Class Roster for Service Center (does not include participant’s UFID numbers) 

5. Click on the title of the desired report.  
NOTE: Click title to go directly to report: ILT Class Roster | ILT Class Roster for Service Center 

6. Select the appropriate ILT Course from the drop down menu. The search box can be used to type in 
code or a partial title.   
 

https://mytraining-ufshands.sumtotal.host/Core/pillarRedirect?relyingParty=AdvancedReport&url=https:%2F%2Fmytraining-ufshands.sumtotal.host%2Fjasperserver-pro/flow.html%3F_flowId%3DviewReportFlow%26reportUnit%3D%2FCustom/UF/Public_Reports/Reports/ILTClassRoster/UF_Roster_Report
https://mytraining-ufshands.sumtotal.host/Core/pillarRedirect?relyingParty=AdvancedReport&url=https:%2F%2Fmytraining-ufshands.sumtotal.host%2Fjasperserver-pro/flow.html%3F_flowId%3DviewReportFlow%26reportUnit%3D%2FCustom/UF/Public_Reports/Reports/ILTClassRoster/UF_Roster_Report_for_Service_Center
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NOTE: New ILT Courses and sessions will not be available in this report until the day after being 
added to the system.  

 
7. Review the date populated in the Date drop down menu.   

 

 
 

8. Select Apply.  
9. The report populates with all Registered users. The last page will include a list of those on the Wait 

List, if applicable.  
 

NOTE:  This report includes live data within 3 minutes of the activity’s roster being modified.  
 

10. Click the export button to print the report as a PDF.  
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Manually Create Roster 
This section demonstrates steps for copying and pasting roster data into a pre-defined Excel template that is 
used by UF Training & Organizational Development. If a customized roster template is desired, please ensure 
the following data fields are included: 

• Activity name 
• Activity code 
• Start date 
• End date (if different from start date) 
• Start time 
• End time 
• Location (room and building) 
• Instructor 
• Participant UFID 
• Participant name 
• Participant signature 

 
1. Obtain the roster template from the myTraining Partner Program Toolkit or use your own spreadsheet  
2. Go to mytraining.hr.ufl.edu, select the University of Florida option, log in with GatorLink credentials 
3. Click on Administration 
4. Navigate to Learning Management > Activity Management > Learning Activities 
5. Search for the class and go to Edit > Manage Roster 
6. Fill in the learning activity details (i.e. name, date, time, location, instructor, etc.) in the spreadsheet 

o Most learning activity details can be viewed on the search results screen 
 

NOTE: Once all learning activity details have been filled in on the roster template, the next part of the 
process is to gather roster data and import it from myTraining into the roster template (i.e. names and 
UFIDs) 
 

7. On the Activity Roster screen, change the “Show Records” dropdown menu to 250 (or any other 
number higher than that of the enrollment – this is to ensure all records are viewable) 
 

 
 
  

http://training.hr.ufl.edu/instructionguides/mpp/in-class-roster_template.xls
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8. Click on Filters 
 

 
 

9. In the Status field drop-down menu, select Registered  
10. Click Apply 

 

 
 

11. Click the Excel icon to export the roster to Excel 
 

 
 

12. For “Pages to Export” select All pages 
13. For “File Type” select Character delimited text 
14. Click Next 
15. Click File 1 
16. Click OK 
17. The exported roster should open in a new tab or browser window 
18. Access the new tab or browser window and select Open to open the Excel file 
19. Highlight column A 
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20. Select the DATA tab and then select Text to Columns 
21. Select Delimited > Next 
22. In the Delimiters column, check the box next to Tab and Comma 
23. Click Next 
24. Highlight the User Number column and select Text for the Column data format 
25. Click Finish 
26. Resize all columns so all data can be viewed 
27. Select data to be copied into the roster template and use CRTL + C to copy 
28. Right click in the cell in the roster template to copy the data into, navigate to Paste Special and select 

Values 
29. Once all registered participant information has been copied into the roster template, navigate back to 

the learning activity 
30. Change the “View” dropdown menu to Waiting list 

 

 
 

31. If there are no learners on the waiting list, no action is needed 
32. If there are learners on the waiting list, their information needs to be added to the classroom roster 

(this can be done manually, or the waiting list can be exported to an Excel/CSV file, following the 
instructions above) 

33. Indicate “Waiting List” at the bottom of the classroom roster: 
 

 
 

34. Once all information has been added for registered and waitlisted learners (if applicable), print each 
roster (or save a local, electronic copy for activities being held off-site) 

35. If multiple rosters need to be printed for the same day, use the breadcrumb trail to navigate back to 
learning activity search results: 
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Processing Rosters – Scheduled Activities 
For ILT activities that are scheduled in advance and made available for registration via myTraining, upon 
conclusion of the activity, rosters must be processed, and attendance records updated. It is a best practice to 
process ILT rosters the same business day (if possible), or within three business days. The date on which an ILT 
roster is processed can impact the length of time the associated evaluation is available to participants.  
 
Roster is Processed on the Same Day of the Training 
Roster is Processed One or More Days After Training Occurred 
 
 
Roster is Processed on the Same Day of the Training 

1. Navigate to mytraining.hr.ufl.edu > University of Florida > log in with GatorLink credentials 
2. Navigate to Administration > Learning Management > Activity Management > Learning Activities 
3. Search for and locate the correct learning activity 
4. Select Edit > Manage Roster  
5. Change the “Show Records” dropdown menu to 100 to ensure all records are viewable 
6. Click on Filters 
7. In the Status field drop-down menu, select Registered  
8. Click Apply 
9. Using the signed roster as a guide, verify the attendance status in myTraining: 

o For those participants with a status of “Registered,” that did not sign the roster, write ‘No 
show’ in the signature field on the printed roster. 
 Select the box next to the left of each name with ‘No show’ on the printed roster  
 Change the Status dropdown menu to No show  
 Click Apply 
 Click Ok 

o For those participants that did not sign the roster with a status of “Canceled,” write “Canceled” 
in the signature field on the printed roster (no action is needed for these records in myTraining) 

o For those participants with a status of “Registered,” that signed the roster, write ‘’ next to the 
signature on the printed roster. 
 Select the box next to the left of each name with a ‘’ next to the signature.  
 Change the following  

• Status dropdown menu to Attended 
• “Passed” dropdown menu to reflect Yes 
• “Completed” dropdown menu to reflect Yes 

 Click Apply 
 Click Ok 

10. Verify the activity roster reflects statuses of registered, canceled, and no show only. Edit learner’s 
attendance status as needed.  
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11. Within the Activity Roster page, navigate to the “View” dropdown menu and select Waiting list 
 

 
 

12. Review the list: 
o If there are no learners listed, proceed to step 13. 
o If there are learners listed, determine if they are listed on the signed roster with a signature 

next to their name: 
 For participants who attended, select the checkbox next to each name and click Move 

to Roster 
 For those participants on the waiting list who did not attend, select the checkbox next to 

each name and click Remove 
 Once the waiting list has been cleaned up, navigate back to the “View” dropdown menu 

and select Completion information 
13. If there are additional participants listed on the signed roster, click Add 
14. Click Continue 
15. Click Add in the “Available Users” section 
16. By default, “Select viewable users” will be selected, it is okay to leave this as-is 
17. Click Next 
18. Enter the UFID or participant name in the Search field, click the grey “Go” arrow 
19. Select the check box next to the correct participant’s name 
20. Click OK 
21. Repeat this process until all additional participants are listed in the “Available Users” section 
22. Ensure all participant names are selected, then click the top arrow in the center of the page to move 

these records to the registration list 
23. Click Submit 
24. Select the box next to the left of each name with a ‘’ next to the signature.  

o Change the following  
 Status dropdown menu to Attended 
 “Passed” dropdown menu to reflect Yes 
 “Completed” dropdown menu to reflect Yes 

25. Click Apply 
26. Click Ok 
27. Click once in the Search box and select the Enter key on the keyboard to return to the complete activity 

roster 
28. Click on Filters 
29. In the Status field drop-down menu, select Attended  
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30. Click Apply 
31. Ensure the “Records” number matches the number of signatures on the printed roster 
32. If this number does not match, compare each participant name to the corresponding record in 

myTraining; once the discrepancy is located, update the attendance status in myTraining as needed 
and/or indicate this on the printed roster as well 

33. Once the “Records” number in myTraining and number of signatures on the printed roster are 
congruent, submit the roster for scanning to the HR Assistant 

 

Roster is Processed One or More Days After Training Occurred 
1. Navigate to mytraining.hr.ufl.edu > University of Florida > log in with GatorLink credentials 
2. Navigate to Administration > Learning Management > Activity Management > Learning Activities 
3. Search for and locate the correct learning activity 
4. Click Edit > Properties 
5. Click Send to Stage 
6. Go to Optional > Registration > Evaluations 
7. Evaluation Status 

o If there is no evaluation present, click Cancel, Validate for Production, and then Move to 
Production (not all trainings have an evaluation, so in that case there’s no need to configure 
evaluation properties). Continue to Step 12.  

o If there is an evaluation present, select the checkbox next to the evaluation name and click Edit. 
Continue to Step 8. 

8. In the “Trigger offset” field, enter the number of days’ difference between when the activity was held 
and the date the roster is being processed (i.e. if the class was held on the 28th, and the roster is being 
processed on the 31th, the trigger offset value would be 3) 

o This value can be calculated by subtracting the class date from the current date, or simply by 
counting the number of days that have passed since the class was held, but not including the 
date the class was held in that count (i.e. 31 – 28 = 3, from the example above) 
NOTE: The vendor suggests we use a trigger offset of at least 3 even if there is a 1-2 day 
difference.  

9. Confirm the “Activity Evaluation date” reflects a date/time that is prior to the ILT Class start date. (If it 
is past this date, no one will receive an evaluation to complete) 

10. Click OK and then click OK again 
11. Click Validate for Production then Move to Production 
12. Select Roster.  
13. Change the “Show Records” dropdown menu to 100 to ensure all records are viewable 
14. Click on Filters 
15. In the Status field drop-down menu, select Registered 
16. Click Apply 
17. Using the signed roster as a guide, verify the attendance status in myTraining: 

o For those participants with a status of “Registered,” that did not sign the roster, write ‘No 
show’ in the signature field on the printed roster. 
 Select the box next to the left of each name with ‘No show’ on the printed roster  
 Change the Status dropdown menu to No show  
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 Click Apply 
 Click Ok 

o For those participants that did not sign the roster with a status of “Canceled,” write “Canceled” 
in the signature field on the printed roster (no action is needed for these records in myTraining) 

o For those participants with a status of “Registered,” that signed the roster, write ‘’ next to the 
signature on the printed roster. 
 Select the box next to the left of each name with a ‘’ next to the signature.  
 Change the following  

• Status dropdown menu to Attended 
• “Passed” dropdown menu to reflect Yes 
• “Completed” dropdown menu to reflect Yes 

 Click Apply 
 Click Ok 

18. Verify the activity roster reflects statuses of registered, canceled, and no show only. Edit learner’s 
attendance status as needed.  

19. Within the Activity Roster page, navigate to the “View” dropdown menu and select Waiting list 
 

 
 

20. Review the list: 
o If there are no learners listed, proceed to step 21. 
o If there are learners listed, determine if they are listed on the signed roster with a signature 

next to their name: 
 For participants who attended, select the checkbox next to each name and click Move 

to Roster 
 For those participants on the waiting list who did not attend, select the checkbox next to 

each name and click Remove 
 Once the waiting list has been cleaned up, navigate back to the “View” dropdown menu 

and select Completion information 
21. If there are additional participants listed on the signed roster, click Add 
22. Click Continue 
23. Click Add in the “Available Users” section 
24. By default, “Select viewable users” will be selected, it is okay to leave this as-is 
25. Click Next 
26. Enter the UFID or participant name in the Search field, click the grey “Go” arrow 
27. Select the check box next to the correct participant’s name 
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28. Click OK 
29. Repeat this process until all additional participants are listed in the “Available Users” section 
30. Ensure all participant names are selected, then click the top arrow in the center of the page to move 

these records to the registration list 
31. Click Submit 
32. Select the box next to the left of each name with a ‘’ next to the signature.  

o Change the following  
 Status dropdown menu to Attended 
 “Passed” dropdown menu to reflect Yes 
 “Completed” dropdown menu to reflect Yes 

33. Click Apply 
34. Click Ok 
35. Click once in the Search box and select the Enter key on the keyboard to return to the complete activity 

roster 
36. Click on Filters 
37. In the Status field drop-down menu, select Attended 
38. Click Apply 
39. Ensure the “Records” number matches the number of signatures on the printed roster 
40. If this number does not match, compare each participant name to the corresponding record in 

myTraining; once the discrepancy is located, update the attendance status in myTraining as needed 
and/or indicate this on the printed roster as well 

41. Once the “Records” number in myTraining and number of signatures on the printed roster are 
congruent, submit the roster for scanning to the HR Assistant 

 

Processing Rosters – Unscheduled Activities 
It is not uncommon for trainers and/or departments to schedule instructor-led training that is not made 
available for registration, in advance, via myTraining. Training Administrators are usually made aware of this 
type of training activity when the roster arrives to be processed. Since there was no advance registration 
made available via myTraining, the activity itself must be created first, then attendance must be manually 
updated, based on the signed roster. 
 
This guide does not include step-by-step instructions for creating ILT activities, please see the Authors and 
Training Administrators Instruction Guide for this information. 
 

1. Once the ILT class activity has been created and located in myTraining, select Edit > Properties 
2. Click Send to Stage 
3. Go to Optional > Registration > Evaluations  
4. Evaluation Status 

o If there is no evaluation present, click Cancel, Validate for Production, and then Move to 
Production (not all trainings have an evaluation, so in that case there’s no need to configure 
evaluation properties). Continue to Step 9.  

o If there is an evaluation present, select the checkbox next to the evaluation name and click Edit. 
Continue to Step 5. 

http://training.hr.ufl.edu/instructionguides/mpp/mpp200_201_instruction_guide.pdf
http://training.hr.ufl.edu/instructionguides/mpp/mpp200_201_instruction_guide.pdf
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5. In the “Trigger offset” field, enter the number of days’ difference between when the activity was held 
and the date the roster is being processed (i.e. if the class was held on the 28th, and the roster is being 
processed on the 31th, the trigger offset value would be 3) 

o This value can be calculated by subtracting the class date from the current date, or simply by 
counting the number of days that have passed since the class was held, but not including the 
date the class was held in that count (i.e. 31 – 28 = 3, from the example above) 
NOTE: The vendor suggests we use a trigger offset of at least 3 even if there is a 1-2 day 
difference.  

6. Confirm the “Activity Evaluation date” reflects a date/time that is prior to the ILT Class start date. (If it 
is past this date, no one will receive an evaluation to complete) 

7. Click OK and then click OK again 
8. Click Validate for Production then Move to Production 
9. Select Roster.  
10. Click Add 
11. Click Continue 
12. In the “Available Users” section, click Add 
13. By default, “Select viewable users” is already selected, it’s okay to leave this as-is 
14. Click Next 
15. Enter the UFID or participant name in the Search field, click the grey “Go” arrow 
16. Select the checkbox next to the correct participant’s name 
17. Click OK 
18. Repeat this process until all additional participants are listed in the “Available Users” section 
19. Ensure all participant names are selected, then click the top arrow in the center of the page to move 

these records to the registration list 
20. Click Submit 
21. Click on Filters 
22. In the Status field drop-down menu, select Registered 
23. Click Apply 
24. Ensure the “Records” number matches the number of signatures on the printed roster 
25. If this number does not match, compare each participant name to the corresponding record in 

myTraining; once the discrepancy is located, add the learner to the activity roster  
26. Once the “Records” number in myTraining and number of signatures on the printed roster are 

congruent, select the checkbox to the left of the “Name” column header (this selects all items on the 
page) 

o Change the following  
 Status dropdown menu to Attended 
 “Passed” dropdown menu to reflect Yes 
 “Completed” dropdown menu to reflect Yes 

27. Click Apply 
28. Click Ok 
 
You are encouraged to keep the paper rosters for a certain amount of time in case there is are any 
discrepancies with the myTraining data. The length of time is up to your department. 
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If you need help with… 
 
Technical issues, contact the UF IT Computing Help Desk at 392-HELP or helpdesk@ufl.edu. 
 
For additional help, please contact UF Training and Organizational Development at (352) 392-4626. 

mailto:helpdesk@ufl.edu
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